What are the minimum system requirements for Palmetto GBA's eServices?

Published 05/31/2022

Answer
To optimize usability of Palmetto GBA's eServices, we recommend that users verify their system adheres to the following minimum requirements:

Operating System

  • Windows 10 (latest security patches)
  • Mac OS X 11.x or above

Supported Internet Browsers*

  • Microsoft Edge: Version 88.x and above
  • Google Chrome: Version 98.x and above  

* Note: IE 11 and FireFox browsers will no longer be supported as of mid-June 2022.

Recommended Screen Resolution: 1024 x 768

Additional Requirements

  • Adobe Acrobat Reader Version DC or Adobe Acrobat Pro Version DC
  • JavaScript enabled
  • Compatibility view disabled
  • Pop-up blocker disabled
  • Use TLS 1.2 selected in browser settings