What are the minimum system requirements for Palmetto GBA's eServices?

Answer:
To optimize usability of Palmetto GBA's eServices, we recommend that users verify their system adheres to the following minimum requirements:

Operating System:

  • Windows 10
  • Mac OS X 10.x

Supported Internet Browsers*:

  • Internet Explorer: Version 11.x
  • Microsoft Edge
  • Mozilla Firefox: Version 69.x 
  • Google Chrome: Version 80.x  

Recommended Screen Resolution: 1024 x 768

Additional Requirements:

  • Adobe Acrobat Reader Version X or Adobe Acrobat Pro Version X
  • JavaScript enabled
  • Compatibility view disabled
  • Pop-up blocker disabled
  • Use TLS 1.2 selected in browser settings

Please note: Although eServices may still be accessible without meeting these minimum requirements, we cannot guarantee the functionality or layout presented.

*We recommend always using the most current browser version that is available.